Trying to retain complete Cisco Network Chapters (including configurations)

3 posts / 0 new
Last post
#1 4 January, 2018 - 14:50
Offline
Joined: 1 week 6 days ago

Trying to retain complete Cisco Network Chapters (including configurations)


Hi, I have been trying for at least 15 years to find a solution to the lack of remembering commands and chapters of books,.
The biggest problems I have is to read a Cisco book and not being able to remember huge parts of that..
Do you have examples or links that I could investigate in order to train myself to read through IT books and being able to retain them better?

Thanks in advance!

Gordon.
For example:
crypto ikev2 profile IKEv2Profile
match identity remote address 20.0.X.3 255.255.255.255
authentication local pre-share
authentication remote pre-share
keyring MYKEY
ip access-list extended INST
permit ip host 111.111.111.111 host 33.33.33.33
crypto map SVPN 10 ipsec-isakmp
set peer 20.0.X.3
set ikev2-profile IKEv2Profile
match address INST
interface G0/0
crypto map SVPN
ip route 33.33.33.33 255.255.255.255 10.0.X.14
CSR-3/4:
crypto ikev2 keyring MYKEY
peer Router
address 10.0.X.1
pre-shared-key local cisco
pre-shared-key remote cisco
crypto ikev2 profile IKEv2Profile
match identity remote address 10.0.X.1 255.255.255.255
authentication local pre-share
authentication remote pre-share
keyring local MYKEY
ip access-list extended INST
permit ip host 33.33.33.33 host 111.111.111.111
crypto map SVPN 10 ipsec-isakmp
set peer 10.0.X.1
set ikev2-profile IKEv2Profile
match address INST
interface G1
crypto map SVPN
ip route 111.111.111.111 255.255.255.255 20.0.X.14

5 January, 2018 - 09:42
Offline
Joined: 2 years 10 months ago

Quote:
For example:
crypto ikev2 profile IKEv2Profile
match identity remote address 20.0.X.3 255.255.255.255
authentication local pre-share
authentication remote pre-share
...

Is that a list of commands to be memorized in order or a list of topics, each with a lot of information to memorize? (I'm not very familiar with networking.)

6 January, 2018 - 23:12
Offline
Joined: 4 months 2 weeks ago

It would seem to me that unless someone here is intimately involved with IT, that you won't get too much out of discussing it here. Unless I'm in IT, trying to memorize your example would be akin to memorizing random and meaningless words and numbers, which, I believe, would be totally useless.

The people in memory competitions can memorize random words and numbers, but all they need to do with them is repeat them. There is no requirement of understanding anything. But, of course, your IT books present information that is presumably not random and indeed has meaning and requires understanding.

So I believe, that is your key. You need to leverage your understanding in order to memorize what really needs to be memorized. It would seem to me that your example needn't actually be memorized. So, part of your example reads "match identity remote address 10.0.X.1 255.255.255.255". I think it's clear that you don't have to actually memorize the given remote address: that would be totally pointless. Perhaps, as part of a list of things that are done in order to set up a remote link, it would be helpful to memorize "match identity remote address" and other commands in the correct sequence; at least the concept of them and not the actual words of course, since any IT professional would be aware of the required syntax for particular commands due to use (natural memory).

So, it is at this point, that memory systems can help you memorize command sequences, system architectures, acronyms, protocols, etc. But your example does little to explicate what it is you are really after. A quick scan of a networking fundamentals book does not show page after page of the stuff you used as an example. But, rather explanations of architectures and protocols and how they work. If you think you need to memorize countless reams of stuff as in your example, I think you are misguided, and you need to re-think what it is you actually need to memorize

Download our free ebook! Just click the "Sign up" button below to create an account, and we'll send you a free ebook with tips on how to get started.

Related content: